Minitab

Introduction

Starting Minitab

Minitab is a general-purpose data analysis system for
organising, analysing and reporting of statistical data. Data is
organised into worksheets consisting of rows and columns of
data rather like a conventional spreadsheet. There are
facilities for retrieving, editing and saving worksheets as well
as commands for performing actions on selected data.
Graphical output of results to both screen and printer is
available.

The Minitab interface consists of windows, menus and
dialogue boxes but a command language is also available for
flexibility and speed. There are several different windows, for
example, a Data window in worksheet format; a Session
window that displays results and Graph windows for high-
resolution graphs.

To start Minitab, choose the Minitab option from the
Public>Maths. and Stats>Minitab (stats) menus:
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On start up, two windows are visible, with Title, Menu and
Toolbars above them:
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The Title bar contains the minimise, maximise and close
buttons on the right hand side. The Menu bar consists of the
usual Windows menus, plus some specific to Minitab, such as
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The Session Window

The Data Window

Entering Commands

Dialogue Boxes

2 Minitab

Calc and Stat. Details of the menus are given in the Appendix
to this chapter.

The Toolbar provides quick access to some of the more
commonly used menu options. Pointing to a button on the
Toolbar will display its function.

The Session window in the top half of the screen will display
the commands you enter and the output generated. It contains
the prompt MI'B> at which you can type Minitab commands if
you are familiar with them. Alternatively, you can choose
commands from the Menus and they will automatically
appear at the prompt as if you had typed them. You can
intersperse menu commands and typed commands, or just
use one or the other, as you prefer.

The Session window can also be used to generate reports and
to add comments to the output. You can cut, copy, and paste,
change fonts, find and replace numbers and text and print the
window.

The Data window displays the current worksheet in a
spreadsheet format, with rows and columns that intersect to
form individual cells. The size of the worksheet should be
100,000 cells. If your computer is low on memory it may be
smaller than this. You can have only one Data Window and
worksheet open at a time.

In the Data window you can enter columns of data into the
worksheet, name, resize, and format columns and cut, copy,
or paste the content cells to and from the Clipboard.

Although the Data window has rows and columns, it is not a
spreadsheet like Microsoft Excel. Cells contain values that you
type or generate with commands; they cannot contain
formulas that update values from data based in other cells.

You can issue commands in Minitab in two ways either by
choosing them from the menu bar, or, if you are already
familiar with the commands, by typing them at the MI'B>
prompt in the Session window.

When you choose items from a menu which are followed by an
ellipsis (...), dialogue boxes appear. When you select items
followed by the symbol >, submenus with more commands
appear.

If a menu command is dimmed, the item is currently
unavailable. Sometimes whole menus are dimmed, indicating
that all the commands in the menu are unavailable.

If a command requires information from you, Minitab will
open a dialogue box; if not, Minitab executes the command
immediately.

To leave a menu selection at any time, move the mouse pointer
off the menu and release the button.

Choosing a command from a menu usually opens a dialogue
box allowing you to choose variables and options. If you have
questions about any of the options, click the Help button in the
bottom left corner of the dialogue box.



Entering Data

Data From Files

Printing Worksheets

Saving Worksheets

To enter data into the worksheet:

= Position the mouse cursor in the first cell by pointing and
clicking in it.

Type the data into the cell.

Press RETURN to move down the column to the next cell or

the tab key to move along the row to the next cell on the
right.
The columns in the Data window are numbered C1, C2 etc. but
you can a also give each column a meaningful name by typing
into the blank cell below the column number.

=
=

For example, typing in two columns of data and naming them
Varl and Var2, would result in the Data window looking like
this:
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If your data are stored in a file, you can open the file directly
into the worksheet. To replace the contents of the current
worksheet with data from a file, choose Open Worksheet from
the File menu. From the resulting dialogue box, select the type
of file you want to open and choose it from the list or type in the
file’'s name directly.
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You can open many types of files, including plain text, Excel,
and dBASE files. To see how the data will look when in the
worksheet, click on the Preview button before opening it.
Preview will also allow you to change column names or
numbers and choose which columns to import.

The Options button in the Open file dialogue box allows you to
give special instructions to Minitab on how the data is
organised in the file, such as how the columns are delimited
(space, tabs etc. ).

To print your worksheet, make the Data window active (click
in the window, or press CTRL-D), then choose Print Window
from the File menu.

To save the data in a worksheet, use Save Current Worksheet
from the File menu. If you want to rename a worksheet or
save it to a new location use Save Current Worksheet As. (Note
that this will not save any graphs or output from the Session
window - just the data).

When the dialogue box appears, make sure the correct file type
appears in the ‘Save as type:’ box. Then enter the file name of
your choice in the File Name box. Select the correct drive and
directory as necessary to tell Minitab where to save the file.
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Analysing Data

Minitab

Most of the time you will probably want to save your worksheet
as a Minitab worksheet (.mtw) file, since this is the fastest,
most efficient way to save all the worksheet information,
including columns, stored constants, matrices, variable
names, and Data window settings.

Save your worksheet as a Minitab portable worksheet (.mtp
file) when you want to export the data to Minitab running on a
different type of computer, such as a mainframe or a
Macintosh.

In addition to the standard format, you can save your
worksheet data in several other file formats. Some others
include:

Lotus Symphony (WR?)

Minitab portable worksheet (MTP)
dBASE (DBF)

Excel (XLS)

Quattro Pro (WB1,WQ1)

Text file (TXT, DAT)

Lotus 1-2-3 (WK?)

If you save your worksheet in a non-Minitab format, such as
an Excel, Lotus, or text file, Minitab will save columns and
(optionally) column names. It will not save stored constants or
matrices. If you want to save that data as well, you must copy
it to columns first.

Minitab provides many different tools for analysing data. For
example, to derive some basic, descriptive statistics for one of
the columns of data entered previously :

= Open the Stat menu or press ALT-S

= Choose Basic Statistics or press B

= Choose Display Descriptive Statistics to produce a dialogue
box

= Double-click on the column name or number in the list on
the left. The name will appear in the Variables box on the
right:

C1l Varl Yariables:
c2 Var?
Warl

" By wvariable:

Select |
Graphs...
Hel,
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= Click OK.
The output will appear in the Session window like this:
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MTE » Describe 'Varl'. [~
Descriptive Statistics
Variable N Mean Hedian Tr Hean StDev SE Mean
Varl 10 66 .80 £7.00 66 .50 1.76 1.50 _I
Variable Min Max Q1 Q3
Yarl £0.00 76.00 £2.75 70.00
HTE |
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Saving Output  To save the output shown in the Session window, make sure
the Session window is the active window then choose Save
Session Window As from the File menu and type in a name for
the file to contain the saved output.

In the course of a Minitab session, you may generate many
lines of output, commands and comments in the Session
window. The Session window will normally hold up to 15,000
lines.

Remember that the contents of the Session window are
separate from your worksheet and are not saved when you
save the worksheet.

You can save output in two formats; Text (ASCII) files do not
contain any of the fonts that you see in the Session window,
while Rich Text Format (.rtf) files retain the fonts. Both
formats can be opened in most word processors.

You can also save the contents of the Session window using
Minitab’s OUTFILE command at the MTB> prompt.

If you always want the contents of the Session window saved,
you can change your preferences so that the session

contents are saved or discarded automatically.

Producing Graphs High-resolution graphs are produced by default, each graph
appearing in its own window. To plot a simple graph of your
data:

= Choose Plot from the Graph menu to display the Plot
dialogue box:

= Specify a Column number or name for the Y-axis and one
for the X-axis. You can type the names of the columns in
the Y and X text boxes, or you can double-click on the
column names in the Select box on the left:

[C1  var1 ____ Graph variables:
cz Var2
Graph h x ﬂ
1 Varl Var2
2 |
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Data display:
ltem Display |' For each |' Group variables il
1 Symbol Graph
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Graph Editing

Printing Graphs

Saving Graphs

Exporting Graphs

Minitab

= Click on the Annotation button and choose Title from the
list.

= Type the title for your plot in the first line of the Title
subdialogue box.

= Click OK in the Title subdialogue box, and click OK again
in the Plot dialogue box.

The output will appear in a new Graph window like this:
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There are many other types of graph available.

Once you have created a graph, you can edit it in various ways
using special Tool and Attribute palettes. To enter editing
mode double-click on the graph itself or choose Edit from the
Editor menu. The palettes should appear to one side of the
screen. They contain tools for adding text, various shapes and
lines.

To obtain printout of a graph make sure the graph window is
active then choose Print Graph from the File menu.

To save a graph in Minitab format:

= Make the graph window active.

= Choose Save Graph As from the File menu

= Type in a file name. The extension .ngf will be
automatically added.

You can open the graph at a later date and continue editing it
by choosing Open Graph from the File menu

Because high-resolution graphs can be saved in standard
Windows file formats you can import Minitab graphs into
word processing and graphics applications to prepare reports
and presentations.

If you want to use a graph in another application, there are
several ways of exporting it. The easiest way is to copy the
graph to the Windows clipboard by choosing Copy Graph from
the Edit menu. Then switch to the other application and
choose Paste from its Edit menu.

Alternatively, save the graph as a bitmap or an encapsulated
PostScript file. To save the graph as a bitmap file:

= Press ALT-PRINT SCREEN to copy the Minitab window.

= Paste the saved image into the Windows Paint application.
= Edit the image as necessary.



= Save the image as a bitmap.

To save as a PostScript file, check Print to file in the Print
dialogue box and enter a name for the file when prompted.

Character Graphics It is also possible to produce low resolution, character graphs,
using simple keyboard characters (ASCII text). These print on
any printer and can be stored using very little disk space.
Character graphs also work well with text-based electronic
mail systems. To produce a character graph, select from the
Character Graphs option in the Graphs menu.

The Command  This provides a quick way to edit and re-execute commands
Line Editor  executed earlier in your session. To use the command line
editor:

= Highlight some or all of the commands displayed in the
Session window. It is okay if you highlight output as well
as commands.

= Choose Command Line Editor from the Edit menu. The
highlighted commands will appear in the command line
editor dialogue box.

= Edit the commands so they appear as you would like the
commands to be executed. You can add new commands if
you choose. Use CTRL+ENTER for a carriage return.

Press ENTER to resubmit the commands for execution.

The Project Manager  All the worksheets, session commands, graphs and reports of
a Minitab session constitute a Project. The Project Manager
provides a means of viewing, navigating and manipulating
these various components.

To open the Project Manager, choose Project Manager from
the Window menu. A list of folders appears on the left hand
side of a new window:

BB Project Manager =]

|1 Untitled Mame Id Rows Columns | Description
{7 Session

{:I History

{_] Graphs

D FeportPad

{1 Related Documents
-3 Warksheets

(I Constants

A Matrices

4| | i

The Project Manager contains folders that allow you to
navigate, view, and manipulate various parts of your project.
By right-clicking on either the folders or the folder contents,
you can access a variety of menus that allow you to manage
Session window output, graphs, worksheets, command
language, and related project areas.
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The Session Folder

The History Folder

The Graphs Folder

The ReportPad Folder

Related Documents Folder

The Worksheet Folder

8 Minitab

The Session folder contains a list of all Session window output
by command and all graphs. Use this folder to manage
Session window output, for instance to jump to Session
window output, copy, delete, rename, or print Session window
output or graphs or to append Session window output or
graphs to the ReportPad

The History folder displays all session commands, without the
output. This folder provides a convenient overview of what you
have done in your session. If you use the Data window to
change the worksheet, a note is generated in the History
folder.

You can use the History folder for example to select
command(s), then open the Command Line Editor where the
command(s) you selected will automatically appear enabling
you to quickly re-execute them.

You can also create a Minitab macro for repeating an analysis
by first working through the steps using the menus and
dialogue boxes, then copying the resulting session commands
from the History folder, pasting into a word processor. See
Creating a Simple Macro in Session Command Help.

Note that you cannot change the contents of the History folder.

You can use the Graphs folder in the Project Manager to
manage multiple Graph windows. By highlighting the graphs
from the list in the Graphs folder and right-clicking with the
mouse, you can:

= Save, Copy, or Print one or more graphs

« Tile multiple graphs across the Minitab screen for easy
viewing and comparison

* Rename individual graphs
* Append graphs to the ReportPad folder

You can quickly create reports of your data in the Project
Manager ReportPad folder using Append to Report. Use the
ReportPad folder to store graphs, Session window output, and
text (such as user comments and notes). All output in the
ReportPad folder is fully editable, and you can save the
contents of the ReportPad folder as an RTF (Rich Text Format)
file that can be displayed in other applications. You can edit
and print the reports directly from the ReportPad folder, or
open and edit them in a word processing program for
enhanced formatting options.

The Related Documents folder contains a list of program files,
documents or internet URLSs that are related to your Minitab
project. This enables you to quickly access project-related, non-
Minitab files for easy reference

The Worksheet folders and their subfolders (Columns,
Constants, and Matrices) contain an automatically updated
summary of the current worksheet. They are especially useful
to help you keep track of variables if you have a large
worksheet. The Worksheet folders' subfolders provide the
following information:

Constants, matrices, and design summaries are each
displayed in their own separate subfolders within the
Worksheet folder.



Ending A Session

Minitab Appendix
File

Columns

For each column containing data, the Columns subfolder
displays the column name, column ID, number of rows,
number of missing values, column type, and column
description. A T under Type marks text columns, a D under
Type marks date/time data, and an N under Type marks
numeric data.

Constants

For each constant containing data, the constant name, the
constant ID, the value of the constant, and the description of
the constant.

Matrices

For each matrix, the matrix name, the matrix Id, the number
of rows in the matrix, the number of columns in the matrix,
and the matrix description.

Designs

The Design subfolder displays Factors, Runs, Blocks, Base
Design, Replicates, and Center points, as well as the display
order and display units, and the factors and their uncoded
levels.

When you have finished working in Minitab, make sure that
you have saved any data, graphs or session information you
wish to keep, then choose Exit from the File menu. If there is
information that has not been saved, you will be prompted to
save it.

Main Menus

New - opens a new worksheet or project.
Open Project - opens a project file.

Save Project - saves the current project.

Save Project As - saves the current project with a different
name.

Project Description - edits a description of the current project.

Open Worksheet - copies data from a file (Minitab, Excel,
Lotus, text, and others), replacing the current worksheet.

Query Database (ODBC) - imports data from a database file,
such as one saved by Microsoft Access, Oracle, Sybase, or SAS
into the Minitab worksheet.

Save Current Worksheet - saves the current worksheet in an
existing MTW or MTP file.

Save Current Worksheet As - saves worksheet data in a file,
with a choice of many different file formats.

Close Worksheet - closes the current worksheet.
Open Graph - opens a Minitab graph (MGF) file.

Save Session Window As - saves the Session window content to
a file.

Save History As - saves the History folder content to a file.
Save Graph As - saves the current Graph window to a file.
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Edit

Manip

Minitab

Other Files - displays commands for importing and exporting
special text files, and for running an Exec.

Print Session Window - prints the Session window.
Print History - prints the History.
Print Graph Window - prints the current Graph window.

Print Worksheet - prints the contents of the current Data
window.

Print Setup - defines printer specifications.
Exit - exits Minitab.

Most Recently Used Worksheets - The bottom of the File menu
lists the most recently used worksheets. Click any worksheet
listed to open it.

Undo - undoes your most recent editing operation.

Clear/Clear Cells - erases the contents of the highlighted cells,
without moving rows up or columns left.

Delete/Delete Cells - deletes the highlighted text or data.

Copy/Copy Cells - copies the highlighted text or data to the
Clipboard.

Cut/Cut Cells - removes the highlighted text or data and copies
it to the Clipboard.

Paste/Paste Cells - copies the contents of the Clipboard to the
current position in the active window.

Paste Link - creates a new Dynamic Data Exchange link by
pasting an existing link into a Data window.

Links - creates new Dynamic Data Exchange (DDE) links;
changes or removes existing links; gets external data, or
executes an external command.

Select All/Select All Cells - highlights everything in the active
window.

Edit Last Dialog - opens the most recently used dialog box,
with the same selections from the last time you used it.

Command Line Editor - allows you to execute session
commands and/or edit and re-submit previously executed
commands.

Preferences - allows you to specify numerous options to
customize your Minitab environment.

Subset Worksheet - copies specified rows from the active
worksheet to the new worksheet.

Split Worksheet - splits or unstacks the active worksheet into
two or more new worksheets based on one or more variables.

Merge - combines two worksheets into one new worksheet.
Sort - sorts one or more columns of data.
Rank - assigns rank scores to values in a column.

Delete Rows - deletes specified rows from columns in the
worksheet.



Erase Variables - erases any combination of columns, stored
constants and matrices.

Copy Columns - copies columns from one position in the
worksheet to another; can copy entire columns or a subset.

Stack - stacks columns on top of each other to make longer
columns.

Unstack - unstacks (or splits) columns into shorter columns.
Transpose Columns - switches columns to rows.

Concatenate - combines two or more text columns side by side
into one new column.

Code - recode values in columns.

Change Data Type - changes columns from one data type
(such as numeric, text, or date/time) to another.

Display Data - displays data from the current worksheet in the
Session window.

Calc Calculator - does arithmetic using an algebraic expression,
which may contain arithmetic operations, comparison
operations, logical operations, and functions.

Column Statistics - calculates various statistics based on a
column you select.

Row Statistics - calculates various statistics for each row of the
columns you select.

Standardize - centers and scales columns of data.

Extract from Date/Time to Numeric/Text - extracts one or
more parts of a date/time column, such as the year, the
quarter, or the hour, and saves that data in a numeric or a
text column.

Make Patterned Data - provides an easy way to fill a column
with numbers or date/time values that follow a pattern. See
also Generating Patterned Data Overview for related
information.

Make Mesh Data - creates a regular (x,y) mesh to use for
drawing contour, 3D surface and wireframe plots, with the
option to create the z-variable as well.

Make Indicator Variables - creates indicator (dummy)
variables that you can use in regression analysis. See also
Generating Patterned Data Overview for related information.

Set Base - fixes a starting point for Minitab’'s random number
generator.

Random Data - displays commands for generating a random
sample of numbers, sampled either from columns of the
worksheet or from a variety of distributions

Probability Distributions - displays commands to compute
probabilities, probability densities, cumulative probabilities,
and inverse cumulative probabilities for continuous and
discrete distributions.

Matrices - displays commands for doing matrix operations.
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Stat

Graph

Minitab

Basic Statistics

Regression

ANOVA (Analysis of Variance)
DOE (Design of Experiments)
Control Charts

Quality Tools
Reliability/Survival
Multivariate

Time Series

Tables

Nonparametrics

EDA (Exploratory Data Analysis)
Power and Sample Size

Layout - lets you specify where a single graph or several
graphs appear on one page.

Plot - produces scatter plots, line plots, area plots, and spike
plots.

Time Series Plot - produces time series plots.

Chart - generates bar charts, line charts, area charts and
other types of charts.

Histogram - generates histograms.
Boxplot - produces box-and-whisker plots.

Matrix Plot - produces a two-dimensional matrix of separate
scatter plots where the input columns are used for either row
or column variables, depending on the order in which you list
them.

Draftsman Plot - produces a two-dimensional matrix of
separate scatter plots where you specify which columns
should be used for row variables and which should be used for
column variables.

Contour Plot - produces contour plots.
3D Plot - displays a three-dimensional plot.

3D Wireframe Plot - displays a three-dimensional plot of a
surface drawn with a wireframe grid.

3D Surface Plot - displays a three-dimensional plot of a smooth
surface.

Pie Chart - generates pie charts.
Dotplot displays individual points along a number line.

Marginal Plot - produces scatter plots with histograms,
boxplots, or dotplots in the margins.

Probability Plot - assess whether a particular distribution fits
data.



Editor

Window

Help

Stem-and-Leaf - produces a character based stem-and-leaf.

Character Graphs - displays options that produce a variety of
character (as opposed to high-resolution) graphs.

Editor Menu commands are dynamic and change depending
on which window is active. Includes Find and Replace,
formatting and insert/delete functions.

Cascade - arranges all open Minitab windows so that they
overlap with each title bar visible (if possible).

Tile - arranges all open Minitab windows so they fit next to
each other on the desktop and do not overlap (if possible).

Minimize All - reduces all open windows to icons and places
them at the bottom of the screen.

Restore Icons - opens all icons into windows, sized as they
were when last reduced to icons within the session.

Arrange lcons - arranges icons along the bottom of the
Minitab window.

Refresh - redraws the graph in the active window.
Standard Toolbar - display or hide the Standard Toolbar

Project Manager Toolbar - display or hide the Project Manager
Toolbar.

Status Bar - display or hide the Status Bar.
Close All Graphs - closes all Graph windows.

Set Graph Size/Location - determines how Minitab will display
Graph windows.

Session <Ctrl>+<M> - switches you to the Session window,
where you can enter session commands and/or view analysis
results.

Project Manager - switches you to the Project Manager
window, where you can manage windows, graphs,
worksheets, related documents, and project information.

Worksheets and Graphs - all open Graph and Data windows
are listed at the bottom of the Window menu. Click on any
window name to activate the window and bring it to the front
of Minitab. See Multiple Graph Windows Limit for important
information on graphs.

Help - displays a table of contents of information in the Help
system.

Search Help - opens the Windows Index dialog box. Type
keywords to find topics, just like you would skim an index in a
printed manual.

How to Use Help - explains how to use the Windows Help
system, including how to print, copy and paste Help text.

StatGuide - displays the welcome page.
Search the StatGuide - opens the table of contents.

How to Use the StatGuide - opens the How to Use the StatGuide
Help file.

Minitab 13



14

Minitab

Tutorials - opens the Tutorials, which walk you through five
sample sessions of MINITAB 13, showing you step-by-step
how to perform a broad range of analyses.

Search Tutorials - opens the Windows Search or Windows 95
dialog box. Type keywords to find topics, just like you would
skim an index in a printed manual.

Session Command Help - opens Session Command Help
containing documentation on each session command,
including syntax and examples.

Search Session Command Help - opens the Windows Search
or Windows 95 dialog box. Type keywords to find topics, just
like you would skim an index in a printed manual.

Minitab on the Web - At Minitab Inc.'s web site you can get
answers to common technical questions, download macros,
and download free maintenance releases of Minitab. Go to
HTTP://www.minitab.com/ and follow the support links.

About Minitab - displays the serial number, product name,
release number, and other information.



